ご利用中のSmartDBで下記の不具合が発生しておりました。
ご不便、ご迷惑をおかけして申し訳ございませんでした。
発生日時
- 2021/05/14 1:00~3:00(JST)のメンテナンス時間〜
2021/05/15 1:00~3:00(JST)のメンテナンス時間
事象
社員番号を取得する評価式である「lookup([アカウント部品], "employeeNumber")」が利用できない。
評価式の設定画面にも表示されず、設定済みの評価式も正常に動作しない。
発生条件
- 特になし。全ての環境で発生。
回避策
- 現時点で回避策は見つかっていません。
原因
- 文書の閲覧可能なユーザ一覧を実現するにあたり、アカウント情報を取得する処理において性能改善を行っており、その際の処理に問題がありました。
対応
- 2021/05/15 1:00~3:00(JST)のメンテナンス時間でのリリースで解消しています。
リカバリ方法
事象発生期間に登録・更新された文書に対して、「再計算」にてリカバリを実施いただく必要がございます。一括で再計算するには2通りの方法がございますのでご確認いただき、ご対応をお願い申し上げます。
- ビューの「一括処理>文書の再計算」より、対象文書と項目を選択して再計算
ビューに「一括処理」メニューを出していただいて対象の文書を選択していただいたあと、再計算をする対象項目を選択できます。今回、不具合の影響を受けております文書のみを指定して再計算が可能です。
詳細につきましては、以下のドキュメントを参照ください。
・バインダ作成ガイド
└ ビュー定義> 一括処理(プロセス実施、編集、削除、再計算、帳票出力、インデックス再作成)
- サイドメニューの「一括再計算」より、対象項目を一括で再計算
全文書に対して「社員番号」の再計算をしたい場合は、一括再計算の機能もご利用いただけます。
詳細につきましては、以下のドキュメントを参照ください。
・利用者ガイド
└ バインダの利用> 一括再計算