SmartDBをご利用いただき、ありがとうございます。
SmartDBで発生している表題の問題についてお知らせします。
記事公開日:2023年6月16日
発生日時
- 2023/06/16(金) 午前1時~3時の15分間のメンテナンス時間(JST)~
- 2023/06/16(金) 午前8時30分ごろ
事象
ファイルアップロードに失敗する。
この事象は特定の環境においてのみ発生していることを確認しています。
原因
ファイルがアップロードに失敗する環境では、ウィルスチェックの処理がエラーとなっていることを確認しています。
※ファイルがアップロード可能な環境では、ウィルスチェックは正しく実施されています。
特定の経緯で作成された環境のみディレクトリのパーミッションに差異があり、この差異がある環境のみライブラリ更新の影響を受けて今回の事象が発生していたことを確認しました ※18:00追記
回避策
事象が発生した場合の回避策は見付かっていません。
対応について
取り急ぎの対応として切り戻しを予定しています。
事象が発生している環境においてはウィルスチェックの切り戻しのための再起動を実施いたします。
→切り戻しを実施して障害状態は復旧しています。
再起動を実施した顧客には個別に連絡しております。※8:35追記
問題のパーミッションを修正して6/23日のリリースにて再度修正の適用を行います。 ※18:00追記
障害発生時の対応状況 ※11:10追記
- 2023/06/16 7:00頃 一部の環境でファイルアップロードに失敗している事象を確認。調査開始。
- 2023/06/16 7:20頃 ウィルスチェックの変更が原因と推定。切り戻し準備を開始。
- 2023/06/16 8:20頃 切り戻し準備完了。対象環境を再起動して切り戻しを実施。
- 2023/06/16 8:30頃 切り戻し完了。引き続き状況を監視。
- 2023/06/16 11:00頃 事象が発生していないことを確認。障害状態は解消と判断。